#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(1[2-9][0-9]|[2-9][0-9]{2})$"
Local $sString = "009" & @CRLF & _
"119" & @CRLF & _
"120" & @CRLF & _
"230" & @CRLF & _
"199" & @CRLF & _
"578" & @CRLF & _
"989" & @CRLF & _
"999" & @CRLF & _
"1000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")