import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(1[2-9][0-9]|[2-9][0-9]{2})$";
final String string = "009\n"
+ "119\n"
+ "120\n"
+ "230\n"
+ "199\n"
+ "578\n"
+ "989\n"
+ "999\n"
+ "1000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}