$re = '/^(1[2-9][0-9]|[2-9][0-9]{2})$/m';
$str = '009
119
120
230
199
578
989
999
1000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);