package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(1[2-9][0-9]|[2-9][0-9]{2})$`)
var str = `009
119
120
230
199
578
989
999
1000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}