# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b19(?=(?:1|2))(\d{2})/20\2/g;t' <<< "1916-1918 subscales for a subject
1998-1914 subscales for a subject
subscales for a subject 1998-1920"