using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b19(?=(?:1|2))(\d{2})";
string substitution = @"20\2";
string input = @"1916-1918 subscales for a subject
1998-1914 subscales for a subject
subscales for a subject 1998-1920";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}