$re = '/\b19(?=(?:1|2))(\d{2})/';
$str = '1916-1918 subscales for a subject
1998-1914 subscales for a subject
subscales for a subject 1998-1920';
$subst = "20\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;