use strict;
my $str = 'Testing Text';
my $regex = qr/(?<!^(?:\S\S|\s\S|\S\s)*)./mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";