#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\?code=([^& ]*)"
Local $sString = "http://www.foo.com?code=234654"
Local $sSubst = "/$1t"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)