using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\?code=([^& ]*)";
string substitution = @"/$1t";
string input = @"http://www.foo.com?code=234654";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}