$re = '/\?code=([^& ]*)/';
$str = 'http://www.foo.com?code=234654';
$subst = "/$1t";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;