re = /\?code=([^& ]*)/
str = 'http://www.foo.com?code=234654'
subst = '/$1t'
result = str.sub(re, subst)
# Print the result of the substitution
puts result