# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\+\\/\-[\s\S]+?\/\/[\s\S]+?(^\};\s+$)//gmx;t' <<< "block \"block1\"
{
ADDSFDJF
SDFSDFSDF
SDFSDFSDF
// subblock: subblock1 [master]
include \"/path/tofile/subblock1.conf\";
+/- subblock subblock1
// subblock: subblock1
subblock \"subblock1\"
{
type TYPE;
file \"name.file\";
details blah blah.
other {sdhsdf};
};
};
file \"dddd.file\";
details blah blah.
// subblock: subblock2
include \"/path/tofile/subblock2.conf\";
+/- subblock subblock2
// subblock: subblock2
subblock \"subblock2\"
{
type TYPE;
file \"name.file\";
details blah blah.
other {sdhsdf};
more fields
};
};"