import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+\\/\\-[\\s\\S]+?//[\\s\\S]+?(^\\};\\s+$)";
final String string = "block \"block1\"\n"
+ "{\n"
+ "ADDSFDJF\n"
+ "SDFSDFSDF\n"
+ "SDFSDFSDF\n\n"
+ " // subblock: subblock1 [master]\n"
+ " include \"/path/tofile/subblock1.conf\";\n"
+ "+/- subblock subblock1\n"
+ "// subblock: subblock1\n"
+ "subblock \"subblock1\"\n"
+ "{\n"
+ " type TYPE;\n"
+ " file \"name.file\";\n"
+ " details blah blah.\n"
+ " other {sdhsdf};\n"
+ " };\n"
+ "};\n\n"
+ " file \"dddd.file\";\n"
+ " details blah blah.\n\n"
+ " // subblock: subblock2\n"
+ " include \"/path/tofile/subblock2.conf\";\n"
+ "+/- subblock subblock2\n"
+ "// subblock: subblock2\n"
+ "subblock \"subblock2\"\n"
+ "{\n"
+ " type TYPE;\n"
+ " file \"name.file\";\n"
+ " details blah blah.\n"
+ " other {sdhsdf};\n"
+ " more fields\n"
+ "};\n"
+ "};";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}