import Foundation
let pattern = #"\+\/\-[\s\S]+?//[\s\S]+?(^\};\s+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
block "block1"
{
ADDSFDJF
SDFSDFSDF
SDFSDFSDF
// subblock: subblock1 [master]
include "/path/tofile/subblock1.conf";
+/- subblock subblock1
// subblock: subblock1
subblock "subblock1"
{
type TYPE;
file "name.file";
details blah blah.
other {sdhsdf};
};
};
file "dddd.file";
details blah blah.
// subblock: subblock2
include "/path/tofile/subblock2.conf";
+/- subblock subblock2
// subblock: subblock2
subblock "subblock2"
{
type TYPE;
file "name.file";
details blah blah.
other {sdhsdf};
more fields
};
};
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)