using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+\/\-[\s\S]+?//[\s\S]+?(^\};\s+$)";
string substitution = @"";
string input = @"block ""block1""
{
ADDSFDJF
SDFSDFSDF
SDFSDFSDF
// subblock: subblock1 [master]
include ""/path/tofile/subblock1.conf"";
+/- subblock subblock1
// subblock: subblock1
subblock ""subblock1""
{
type TYPE;
file ""name.file"";
details blah blah.
other {sdhsdf};
};
};
file ""dddd.file"";
details blah blah.
// subblock: subblock2
include ""/path/tofile/subblock2.conf"";
+/- subblock subblock2
// subblock: subblock2
subblock ""subblock2""
{
type TYPE;
file ""name.file"";
details blah blah.
other {sdhsdf};
more fields
};
};";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}