using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)style\(data-above-the-fold=""true""\)[\s\S]*";
string input = @"DOCTYPE html
html
head
title gulp-gotohead
style.
article {border:1px solid}
style(data-above-the-fold=""true"").
body {font-size:100%}
body{font-size:100%}
body.main{font-size:100%}
body, h1{font-size:100%}
body>h1{font-size:100%}
header {color:#333}
script(data-above-the-fold=""true"").
var head = Head();
head();
body (data-d=""true"")
h1 gulp-gotohead
p
span regex";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}