import Foundation
let pattern = #"(.*)style\(data-above-the-fold="true"\)[\s\S]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
DOCTYPE html
html
head
title gulp-gotohead
style.
article {border:1px solid}
style(data-above-the-fold="true").
body {font-size:100%}
body{font-size:100%}
body.main{font-size:100%}
body, h1{font-size:100%}
body>h1{font-size:100%}
header {color:#333}
script(data-above-the-fold="true").
var head = Head();
head();
body (data-d="true")
h1 gulp-gotohead
p
span regex
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)