package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)style\(data-above-the-fold="true"\)[\s\S]*`)
var str = `DOCTYPE html
html
head
title gulp-gotohead
style.
article {border:1px solid}
style(data-above-the-fold="true").
body {font-size:100%}
body{font-size:100%}
body.main{font-size:100%}
body, h1{font-size:100%}
body>h1{font-size:100%}
header {color:#333}
script(data-above-the-fold="true").
var head = Head();
head();
body (data-d="true")
h1 gulp-gotohead
p
span regex`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}