package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[(20)] [0-9]{3} [0-9]{4} | [(30)] [0-9]{3} [0-9]{4} | [(70)] [0-9]{3} [0-9]{4}`)
var str = `(30) 629 1895`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}