const regex = /[(20)] [0-9]{3} [0-9]{4} | [(30)] [0-9]{3} [0-9]{4} | [(70)] [0-9]{3} [0-9]{4}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[(20)] [0-9]{3} [0-9]{4} | [(30)] [0-9]{3} [0-9]{4} | [(70)] [0-9]{3} [0-9]{4}', 'g')
const str = `(30) 629 1895`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}