re = /[(20)] [0-9]{3} [0-9]{4} | [(30)] [0-9]{3} [0-9]{4} | [(70)] [0-9]{3} [0-9]{4}/
str = '(30) 629 1895'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end