$re = '/[(20)] [0-9]{3} [0-9]{4} | [(30)] [0-9]{3} [0-9]{4} | [(70)] [0-9]{3} [0-9]{4}/';
$str = '(30) 629 1895';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);