using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\b|\s)(\$\S+)\s*(.*?)\s*\1";
string input = @"из Hello $token world$token нужно получить world
из Hello $foo $bar 123 $foo нуэно полусить $bar 123
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}