const regex = /(?<=\b|\s)(\$\S+)\s*(.*?)\s*\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\b|\\s)(\\$\\S+)\\s*(.*?)\\s*\\1', 'gm')
const str = `из Hello \$token world\$token нужно получить world
из Hello \$foo \$bar 123 \$foo нуэно полусить \$bar 123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}