$re = '/(?<=\b|\s)(\$\S+)\s*(.*?)\s*\1/m';
$str = 'из Hello $token world$token нужно получить world
из Hello $foo $bar 123 $foo нуэно полусить $bar 123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);