re = /(?<=\b|\s)(\$\S+)\s*(.*?)\s*\1/m
str = 'из Hello $token world$token нужно получить world
из Hello $foo $bar 123 $foo нуэно полусить $bar 123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end