import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s[^>]*href=\"https?://[^>]*>(.*?)</a>";
final String string = "<a href=\"https://site.ru/*****>слово</a>\n"
+ "<a class=\"m\" href=\"https://site.ru/*****>слово</a>\n"
+ "<a href=\"https://site.ru/*****\" class=\"m\" >слово</a>\n\n"
+ "<a href=\"https://www.site.ru/sistemy-promyshlennogo-konditsionirovaniya/fankoyly/ballu-machine/\" rel=\"nofollow\">слово</a> <br>\n"
+ "<a href=\"https://www.site2.ru/fdescript/1559/?design=1\">слово</a> <br>\n"
+ "<a href=\"https://www.site3.ru/fdescript/997/?design=1\">слово</a> <br>\n"
+ "<a href=\"https://www.site3.ru/fdescript/1003/?design=1\" rel=\"nofollow\">слово</a>\n";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}