re = /<a\s[^>]*href="https?:\/\/[^>]*>(.*?)<\/a>/i
str = '<a href="https://site.ru/*****>слово</a>
<a class="m" href="https://site.ru/*****>слово</a>
<a href="https://site.ru/*****" class="m" >слово</a>
<a href="https://www.site.ru/sistemy-promyshlennogo-konditsionirovaniya/fankoyly/ballu-machine/" rel="nofollow">слово</a> <br>
<a href="https://www.site2.ru/fdescript/1559/?design=1">слово</a> <br>
<a href="https://www.site3.ru/fdescript/997/?design=1">слово</a> <br>
<a href="https://www.site3.ru/fdescript/1003/?design=1" rel="nofollow">слово</a>
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result