// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?is)<a\s[^>]*href="https?://[^>]*>(.*?)</a>"#).unwrap();
let string = "<a href=\"https://site.ru/*****>слово</a>
<a class=\"m\" href=\"https://site.ru/*****>слово</a>
<a href=\"https://site.ru/*****\" class=\"m\" >слово</a>
<a href=\"https://www.site.ru/sistemy-promyshlennogo-konditsionirovaniya/fankoyly/ballu-machine/\" rel=\"nofollow\">слово</a> <br>
<a href=\"https://www.site2.ru/fdescript/1559/?design=1\">слово</a> <br>
<a href=\"https://www.site3.ru/fdescript/997/?design=1\">слово</a> <br>
<a href=\"https://www.site3.ru/fdescript/1003/?design=1\" rel=\"nofollow\">слово</a>
";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}