import Foundation
let pattern = #"<a\s[^>]*href="https?://[^>]*>(.*?)</a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<a href="https://site.ru/*****>слово</a>
<a class="m" href="https://site.ru/*****>слово</a>
<a href="https://site.ru/*****" class="m" >слово</a>
<a href="https://www.site.ru/sistemy-promyshlennogo-konditsionirovaniya/fankoyly/ballu-machine/" rel="nofollow">слово</a> <br>
<a href="https://www.site2.ru/fdescript/1559/?design=1">слово</a> <br>
<a href="https://www.site3.ru/fdescript/997/?design=1">слово</a> <br>
<a href="https://www.site3.ru/fdescript/1003/?design=1" rel="nofollow">слово</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)