#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?>/home/more/Music|).*other"
Local $sString = "/other/more.mp3" & @CRLF & _
"/home/more/Music/more.mp3" & @CRLF & _
"/home/more/Music/Music.mp3" & @CRLF & _
"/home/more/Music/something other.mp3" & @CRLF & _
"/home/more/Music/other/something.mp3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")