re = /^(?>\/home\/more\/Music|).*other/m
str = '/other/more.mp3
/home/more/Music/more.mp3
/home/more/Music/Music.mp3
/home/more/Music/something other.mp3
/home/more/Music/other/something.mp3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end