import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?>/home/more/Music|).*other";
final String string = "/other/more.mp3\n"
+ "/home/more/Music/more.mp3\n"
+ "/home/more/Music/Music.mp3\n"
+ "/home/more/Music/something other.mp3\n"
+ "/home/more/Music/other/something.mp3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}