$re = '~^(?>/home/more/Music|).*other~m';
$str = '/other/more.mp3
/home/more/Music/more.mp3
/home/more/Music/Music.mp3
/home/more/Music/something other.mp3
/home/more/Music/other/something.mp3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);