use strict;
my $str = '//1. support post-livraison
//2. support post livraison
//3. support client post livraison
//4. support client post-livraison
//5. post-livraison
//6. post livraison
//7. support client
//8. support post
//9. client post-livraison
//10. client post livraison
//11. support
//12. livraison';
my $regex = qr/\b(support post-livraison|support post livraison|support client post livraison|support client post-livraison|post-livraison|post livraison|support client|support post|client post-livraison|client post livraison|support|livraison)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}