import re
regex = re.compile(r"\b(support post-livraison|support post livraison|support client post livraison|support client post-livraison|post-livraison|post livraison|support client|support post|client post-livraison|client post livraison|support|livraison)\b", flags=re.MULTILINE)
test_str = ("//1. support post-livraison\n"
" //2. support post livraison\n"
" //3. support client post livraison\n"
" //4. support client post-livraison\n"
" //5. post-livraison\n"
" //6. post livraison\n"
" //7. support client\n"
" //8. support post\n"
" //9. client post-livraison\n"
" //10. client post livraison\n"
" //11. support\n"
" //12. livraison")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")