using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!Vol)(?!Chapter)(?<Series>.+?)(?:\s*\d*[_\-#]\d+|$)";
string input = @"Kodoja #001 (March 2016)
Bleach 001-002
[BAA]_Darker_than_Black_Omake-1
The Archmage Returns After 4000 Years
See You in My 19th Life
The Return of the 8th Class Mage
Kaiju No. 8
Zom 100 - Bucket List of the Dead";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}