import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!Vol)(?!Chapter)(?<Series>.+?)(?:\\s*\\d*[_\\-#]\\d+|$)";
final String string = "Kodoja #001 (March 2016)\n"
+ "Bleach 001-002\n"
+ "[BAA]_Darker_than_Black_Omake-1\n"
+ "The Archmage Returns After 4000 Years\n"
+ "See You in My 19th Life\n"
+ "The Return of the 8th Class Mage\n"
+ "Kaiju No. 8\n"
+ "Zom 100 - Bucket List of the Dead";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}