const regex = /^(?!Vol)(?!Chapter)(?<Series>.+?)(?:\s*\d*[_\-#]\d+|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!Vol)(?!Chapter)(?<Series>.+?)(?:\\s*\\d*[_\\-#]\\d+|$)', 'gm')
const str = `Kodoja #001 (March 2016)
Bleach 001-002
[BAA]_Darker_than_Black_Omake-1
The Archmage Returns After 4000 Years
See You in My 19th Life
The Return of the 8th Class Mage
Kaiju No. 8
Zom 100 - Bucket List of the Dead`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}