re = /^(?!Vol)(?!Chapter)(?<Series>.+?)(?:\s*\d*[_\-#]\d+|$)/m
str = 'Kodoja #001 (March 2016)
Bleach 001-002
[BAA]_Darker_than_Black_Omake-1
The Archmage Returns After 4000 Years
See You in My 19th Life
The Return of the 8th Class Mage
Kaiju No. 8
Zom 100 - Bucket List of the Dead'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end