# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ (?s)
<page>
(
.*?
(?:
(?: <page> | <\/page> )
(*SKIP) (*FAIL)
| {{Infobox
)
.*?
)
(?: <page> (*SKIP) (*FAIL) | <\/page> )
/$1/gx;t' <<< "List of keywords :
keyword1 = <page>
keyword2 = </page>
keyword3 = {{Infobox
Example A:
<page>
text to consider without {{ not-Infobox
</page>
Result => do not extract (or keep or split) this part.
Example B:
<page>
text to consider with {{Infobox here}}
</page>
Result => extract (or keep or split) this part."