$re = '~ (?s)
<page>
(
.*?
(?:
(?: <page> | </page> )
(*SKIP) (*FAIL)
| {{Infobox
)
.*?
)
(?: <page> (*SKIP) (*FAIL) | </page> )
~x';
$str = 'List of keywords :
keyword1 = <page>
keyword2 = </page>
keyword3 = {{Infobox
Example A:
<page>
text to consider without {{ not-Infobox
</page>
Result => do not extract (or keep or split) this part.
Example B:
<page>
text to consider with {{Infobox here}}
</page>
Result => extract (or keep or split) this part.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;