# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?s)
<page>
(
.*?
(?:
(?: <page> | </page> )
(*SKIP) (*FAIL)
| {{Infobox
)
.*?
)
(?: <page> (*SKIP) (*FAIL) | </page> )
"""
test_str = ("List of keywords :\n\n"
"keyword1 = <page>\n"
"keyword2 = </page>\n"
"keyword3 = {{Infobox\n\n"
"Example A:\n\n"
"<page>\n"
"text to consider without {{ not-Infobox\n"
"</page>\n\n\n"
"Result => do not extract (or keep or split) this part.\n\n"
"Example B:\n\n"
"<page>\n"
"text to consider with {{Infobox here}}\n"
"</page>\n\n"
"Result => extract (or keep or split) this part.")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.