using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?s)
<page>
(
.*?
(?:
(?: <page> | </page> )
(*SKIP) (*FAIL)
| {{Infobox
)
.*?
)
(?: <page> (*SKIP) (*FAIL) | </page> )
";
string substitution = @"$1";
string input = @"List of keywords :
keyword1 = <page>
keyword2 = </page>
keyword3 = {{Infobox
Example A:
<page>
text to consider without {{ not-Infobox
</page>
Result => do not extract (or keep or split) this part.
Example B:
<page>
text to consider with {{Infobox here}}
</page>
Result => extract (or keep or split) this part.";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}