#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\+?1\h*)?(?:(\()?\d{3}(?(1)\))[-. ]?\d{3}[-. ]?\d{4})$"
Local $sString = "589-845-2889" & @CRLF & _
"(589)-845-2889" & @CRLF & _
"589.845.2889" & @CRLF & _
"589 845 2889" & @CRLF & _
"5898452889" & @CRLF & _
"(589) 845 2889" & @CRLF & _
"1(589) 845 2889" & @CRLF & _
"+1(589) 845 2889" & @CRLF & _
"1589 845 2889" & @CRLF & _
"1 589 845 2889" & @CRLF & _
"15898452889" & @CRLF & _
"+1207 244 7002" & @CRLF & _
"+1 207 244 7002" & @CRLF & _
"(589) 845-2889" & @CRLF & _
"+1(589) 845-2889" & @CRLF & _
"1(589) 845-2889"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")