import re
regex = re.compile(r"^(?:\+?1\h*)?(?:(\()?\d{3}(?(1)\))[-. ]?\d{3}[-. ]?\d{4})$", flags=re.MULTILINE)
test_str = ("589-845-2889\n"
"(589)-845-2889\n"
"589.845.2889\n"
"589 845 2889\n"
"5898452889\n"
"(589) 845 2889\n"
"1(589) 845 2889\n"
"+1(589) 845 2889\n"
"1589 845 2889\n"
"1 589 845 2889\n"
"15898452889\n"
"+1207 244 7002\n"
"+1 207 244 7002\n"
"(589) 845-2889\n"
"+1(589) 845-2889\n"
"1(589) 845-2889")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")