import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\+?1\\h*)?(?:(\\()?\\d{3}(?(1)\\))[-. ]?\\d{3}[-. ]?\\d{4})$";
final String string = "589-845-2889\n"
+ "(589)-845-2889\n"
+ "589.845.2889\n"
+ "589 845 2889\n"
+ "5898452889\n"
+ "(589) 845 2889\n"
+ "1(589) 845 2889\n"
+ "+1(589) 845 2889\n"
+ "1589 845 2889\n"
+ "1 589 845 2889\n"
+ "15898452889\n"
+ "+1207 244 7002\n"
+ "+1 207 244 7002\n"
+ "(589) 845-2889\n"
+ "+1(589) 845-2889\n"
+ "1(589) 845-2889";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}