using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""arrayKey1"": (?<arrayKey1>[^""]+),[\n\t ]+""arrayKey2"": ""(?<arrayKey2>[^""]+)"",[\n\t ]+""arrayKey3"": ""(?<arrayKey3>[^""]+)"")(?:[\s\S]*)(?:""anotherKey"": ""(?<anotherKey>[^""]+)"")";
string input = @"{
""key1"": ""value1"",
""key2"": ""value2"",
""key3"": ""value3"",
""key4"": [
{
""arrayKey1"": 1,
""arrayKey2"": ""something"",
""arrayKey3"": ""somethingelse""
},
{
""arrayKey1"": 2,
""arrayKey2"": ""something2"",
""arrayKey3"": ""somethingelse2""
},
{
""arrayKey1"": 3,
""arrayKey2"": ""something3"",
""arrayKey3"": ""somethingelse3""
}
],
""some very long text here"": ""
""anotherKey"": ""value"",
""keylast"": ""valuelast""
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}