import re
regex = re.compile(r"(?:\"arrayKey1\": (?<arrayKey1>[^\"]+),[\n\t ]+\"arrayKey2\": \"(?<arrayKey2>[^\"]+)\",[\n\t ]+\"arrayKey3\": \"(?<arrayKey3>[^\"]+)\")(?:[\s\S]*)(?:\"anotherKey\": \"(?<anotherKey>[^\"]+)\")", flags=re.MULTILINE)
test_str = ("{\n"
" \"key1\": \"value1\",\n"
" \"key2\": \"value2\",\n"
" \"key3\": \"value3\",\n"
" \"key4\": [\n"
" {\n"
" \"arrayKey1\": 1,\n"
" \"arrayKey2\": \"something\",\n"
" \"arrayKey3\": \"somethingelse\"\n"
" },\n"
" {\n"
" \"arrayKey1\": 2,\n"
" \"arrayKey2\": \"something2\",\n"
" \"arrayKey3\": \"somethingelse2\"\n"
" },\n"
" {\n"
" \"arrayKey1\": 3,\n"
" \"arrayKey2\": \"something3\",\n"
" \"arrayKey3\": \"somethingelse3\"\n"
" }\n"
" ],\n"
" \"some very long text here\": \"\"\n"
" \"anotherKey\": \"value\",\n"
" \"keylast\": \"valuelast\"\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")